Announcement

Collapse
No announcement yet.

Eastsun, another Rado sister-brand

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • mike184
    replied
    Originally posted by Tim. View Post

    No problem seeing these ones Mike. What's the ultrasonic about, is it just a fancy name for a hi-beat movement?

    This is the one I own. It arrived a few weeks ago and is part of my collection now.

    The additional Enicar-logo(Saturn) and the additional "ultrasonic" is "creative dial design".
    When the dial was refinished, they obviously used an Enicar plunger from that time, matching from the size.
    But that can be removed.
    It came with a serviced movement, runs fine and very exactly and costed just a very few Euros.

    "Ultrasonic" at that time period stands for ultrasonic cleaned movements, which had been new at that time.

    Leave a comment:


  • Tim.
    replied
    No problem seeing these ones Mike. What's the ultrasonic about, is it just a fancy name for a hi-beat movement?
    Last edited by Tim.; 05-12-2019, 03:36 AM.

    Leave a comment:


  • mike184
    replied
    1951schlupradoexactodahp.jpgeastsun31940s326.jpgeastsun11950slady326.jpg

    Leave a comment:


  • Tim.
    replied
    Originally posted by mike184 View Post
    The pics on the screenshots as well as all of the photos of Eastsun-watches in my first post were uploaded with the forum software.
    And they show up in the post and, if I edit it, also in the attachement.

    Only the first 4 photos in my first post are linked from my HP.
    Well, it's very strange then. As to the post disappearing after you edited it, I agree, it's a real pain. It's happened to me on a number of occasions when I've done an edit after I've posted Funky Friday. I usually message Henry and he puts it back up for me, which can of course take quite a while given the time difference between Eastern Australia and Central Canada. It's something to do with the anti-spam settings on the new platform I think. I've found the only way around it is to wait for a reply to the post, once that happens you're free to go ahead and do as many edits as you like without any problem.
    Last edited by Tim.; 05-04-2019, 11:09 PM.

    Leave a comment:


  • mike184
    replied
    The pics on the screenshots as well as all of the photos of Eastsun-watches in my first post were uploaded with the forum software.
    And they show up in the post and, if I edit it, also in the attachement.

    Only the first 4 photos in my first post are linked from my HP.

    Leave a comment:


  • Tim.
    replied
    Originally posted by mike184 View Post

    Hi Tim!

    Yes, I can see it - with Firefox, Chrome and with Edge.
    And I still can see it in my own first post - with Firefox, Chrome and with Edge.
    And Iīm absolutely sure itīs the same link.

    The screenshots in my last post were made with Chrome.
    This is with Firefox:
    Z EOT f.jpg
    Chrome:
    Z EOT g.jpg
    Edge:Z EOT h.jpg
    It's strange indeed that the links should upload using the same browser from my Mac and not from your PC. Although there is then a difference between using a Mac OS and Windows 10. I'm guessing these screenshots will be jpegs uploaded directly from your PC and not links, so perhaps the problem lies with the compatibility of the forum's software when uploading links from the latest version of Windows 10. We'll have to get someone else with the latest Windows 10 to do a test and see if we can repeat the problem.

    Leave a comment:


  • mike184
    replied
    Originally posted by Tim. View Post
    Test. Just linked the photo below from Mike's website, using Firefox. Let's know if you can see it.

    1955schweizuhrenanzeigerxs.jpg
    ]
    Hi Tim!

    Yes, I can see it - with Firefox, Chrome and with Edge.
    And I still can see it in my own first post - with Firefox, Chrome and with Edge.
    And Iīm absolutely sure itīs the same link.

    The screenshots in my last post were made with Chrome.
    This is with Firefox:
    Z EOT f.jpg
    Chrome:
    Z EOT g.jpg
    Edge:Z EOT h.jpg

    Leave a comment:


  • Tim.
    replied
    Test. Just linked the photo below from Mike's website, using Firefox. Let's know if you can see it.

    1955schweizuhrenanzeigerxs.jpg
    I have tried viewing the original post with, Firefox, Chrome and Android.

    Firefox looks like this.

    Screen Shot 2019-05-05 at 5.22.46 AM.png
    Chrome and Android look like this.

    Screen Shot 2019-05-05 at 5.22.07 AM.png
    Last edited by Tim.; 05-04-2019, 03:26 PM.

    Leave a comment:


  • mike184
    replied
    Pics(screenshots):

    Z EOT b.jpg
    Z EOT c.jpg
    Z EOT d.jpg
    Z EOT e.jpg

    Leave a comment:


  • mike184
    replied
    The Eastsun info is on my HP meanwhile, just click HERE.

    Originally posted by earloffarnborough View Post
    No pics in the first post. Second post has photos.
    IMHO, the forum software is still a mess.
    How can it be that I see all of the pictures, both linked and uploaded(with the forum software) ones, in three of the worldīs most popular browsers on my PC - and others canīt?


    Hi Brad!
    Thanks for the pics, but they are already in my first post.


    EDIT:
    I just edited the first post, this time with Chrome instead of Firefox.
    All of the photos are present, also the uploaded ones, a second time in the attachment below.
    So I just removed the empty spaces between the text and saved.
    An error report popped up. But the changes are saved though. And all of the photos are still present(for me at least).
    BTW, I already posted this thread 2 days ago, After editing (to correct a mistake), it disappeared completely.
    I had been clever enough to save a backup and posted a second time yesterday.
    Itīs not a fun starting threads here.

    Z EOT.jpg
    Last edited by mike184; 05-04-2019, 01:48 PM.

    Leave a comment:


  • Watch Carefully
    replied
    One more:

    s-l1600.jpg

    Another reference number for you, Mike:

    s-l1600.jpg

    Here's a movement photo. AS 1430, I believe, from the markings on the caseback:

    s-l1600.jpg
    Last edited by Watch Carefully; 05-04-2019, 09:49 AM.

    Leave a comment:


  • earloffarnborough
    replied
    No pics in the first post. Second post has photos.

    Leave a comment:


  • mike184
    replied
    Thanks, Tim!


    Mysteries of the www - or of the forum software ...

    The first 4 pics are linked from my HP - they show the "Swiss Advisory", the registration of Eastsun, some WWII-Rados and Exactos for compare on a photo and on an old Schlup& Co-Ad. I see all of them with Firefox and Chrome. With Edge, I see the first two, not the last two of them. But they are all to see on my HP: Exacto.

    All of the Eastsun-pics are uploaded to the forum - I can see all of them in Firefox, Chrome, Edge. Only in Firefox, beside each pic, a pic-symbol shows up, as if a pic was missing. But theyīre there, all of them, so why ever.

    Anyone else with problems?

    BTW, I use Windows 10, latest version, Firefox/Chrome/Edge latest versions.

    Leave a comment:


  • Tim.
    replied
    Hi Mike, very interesting info as always. I don't know if it's just me but the photo links in the original post seem to be broken, I can't see them anyway, anyone else?

    Leave a comment:


  • mike184
    replied
    Hi!



    Found a few others, one ladiesī.
    All of them without movement pic.

    5 Eastsun 1950s a.jpg



    6 Eastsun 1950s a.jpg6 Eastsun 1950s b.jpg


    7 Eastsun 1950s a.jpg
    7 Eastsun 1950s c.jpg


    8 Eastsun 1950s a.jpg
    8 Eastsun 1950s b.jpg


    9 Eastsun 1950s a.jpg
    9 Eastsun 1950s b.jpg


    1 Eastsun Lady 14k a.jpg
    1 Eastsun Lady 14k b.jpg

    Leave a comment:

Working...
X